Home Блог Категории Ошибка при заполнении 2-НДФЛ (ФНС) ЗиКБУ 1.0.90.1
Ошибка при заполнении 2-НДФЛ (ФНС) ЗиКБУ 1.0.90.1 PDF Печать E-mail
Автор: Программист   
29.01.2016 07:09

{ОбщийМодуль.СправкиПоНДФЛ.Модуль(224)}: Преобразование значения к типу Число не может быть выполнено
ЗачтеноАвансовыхПлатежей = ЗачтеноАвансовыхПлатежей + СтрокаИтогов.ЗачтеноАвансовыхПлатежей;

Процедура УточнитьСтатусРаботающегоПоПатенту(НалоговыйПериод, СтрокиИтогов, ОписаниеСправки) Экспорт

Если НалоговыйПериод >= Год(ПроведениеРасчетов.ДатаИзмененияПорядкаИсчисленияНалогаДляИностранцев()) Тогда
ЗачтеноАвансовыхПлатежей = 0;
Для каждого СтрокаИтогов Из СтрокиИтогов Цикл
ЗачтеноАвансовыхПлатежей = ЗачтеноАвансовыхПлатежей + СтрокаИтогов.ЗачтеноАвансовыхПлатежей;
КонецЦикла;
Если ЗачтеноАвансовыхПлатежей > 0
И ЗначениеЗаполнено(ОписаниеСправки.ДатаУведомленияАвансовыеПлатежи)
И ЗначениеЗаполнено(ОписаниеСправки.КодНалоговогоОрганаУведомленияАвансовыеПлатежи)
И ЗначениеЗаполнено(ОписаниеСправки.НомерУведомленияАвансовыеПлатежи)
И ОписаниеСправки.СтатусНалогоплательщика = Перечисления.СтатусыНалогоплательщиковПоНДФЛ.Резидент Тогда

ОписаниеСправки.СтатусНалогоплательщика = Перечисления.СтатусыНалогоплательщиковПоНДФЛ.НерезидентРаботающийНаОснованииПатента
КонецЕсли;
КонецЕсли;

КонецПроцедуры

--------------------------------------------------------------------------------

!!!  СтрокаИтогов.ЗачтеноАвансовыхПлатежей = NULL

--------------------------------------------------------------------------------

Не подтягиваются реквизиты имущественного вычета:

Обновлено 29.01.2016 07:24
 
Баннер
© 2020 АВРО. Все права защищены.
Joomla! — свободное программное обеспечение, распространяемое по лицензии GNU/GPL.